Error47 on the 5th chapter

Phantasmagoria 2 - A Puzzle of Flesh (Sierra)
Post Reply
Posts: 1
Joined: Sun Apr 19, 2009 8:19 am

Error47 on the 5th chapter

Post by schpitz »

Hey there,
First of all, it's a great game and it worked wonderfull till the 5th chapter (disc).
When i see the movie with the mother, and then i have to choose if to run to her or from her, i get the following "Error47" massage:

We're sorry, you have ecountered an internal game error. please reastart your game and restore a saved game... (yada yada yada)
Error 47: Not an object: $18e
Script #63016 ($fe34924+)

Is this error familiar with anyone?
How can i fix it and finish the game?
Posts: 1
Joined: Sun Jul 12, 2009 3:56 am

Re: Error47 on the 5th chapter

Post by Plasma »

I've got the exact same problem, except that I don't get the "error 47: Not an object". Instead it flat out freezes for 5 seconds and then tells me "this program has encountered an illegal error and must close" and then boots me back to my desktop. I encountered the error 47 in the 1st chapter, but used the offical P2FIX.exe patch I downloaded which fixed the problem, despite the fact this patch is already suppose to be included in the installer, but it didn't fix the 5th chapter backyard with mom part. It always crashes before I can do ANYTHING. Anyway to fix this? The game is unfinishable unless this can be solved.

NVM, I managed to solve the problem. Although I have no idea how. I just fiddled with a bunch of random settings and all of a sudden it worked.
Post Reply